Build #13

Build: #13 failed Child of CDAP-DRC7115-397

Build result summary

Details

Completed
Duration
16 minutes
Labels
None
Agent
bamboo-agent18
Revision
305441da0a4b46ab6e499ce78b2c9ab4ba7143ab 305441da0a4b46ab6e499ce78b2c9ab4ba7143ab

No failed tests found, a possible compilation error occurred.

Responsible

No one has taken responsibility for this failure

Code commits

Author Commit Message Commit date
Bhooshan Mogal <bhooshan@google.com> Bhooshan Mogal <bhooshan@google.com> 305441da0a4b46ab6e499ce78b2c9ab4ba7143ab 305441da0a4b46ab6e499ce78b2c9ab4ba7143ab Merge pull request #11291 from dbuzhorkaa/feature-documentation-dark-theme-4.3
Change documentation theme to dark
Denys Buzhor <dbuzhor@kaaiot.io> Denys Buzhor <dbuzhor@kaaiot.io> a2d4b7b5f052692d7cb478ccbd9d2870fe7ec204 a2d4b7b5f052692d7cb478ccbd9d2870fe7ec204 Change documentation theme to dark

Error summary for Build Artifacts

The job generated some errors, drill down into the full build log for more details.

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
npm WARN deprecated react-file-download@0.3.2: WARNING: This project has been renamed to js-file-download. Use js-file-download instead.
npm WARN deprecated core-js@1.2.7: core-js@<2.6.8 is no longer maintained. Please, upgrade to core-js@3 or at least to actual version of core-js@2.
npm WARN deprecated babel-preset-es2017@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read https://babeljs.io/env to update!
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated gulp-header@1.8.2: Removed event-stream from gulp-header
npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated extract-text-webpack-plugin@3.0.0: Deprecated. Please use https://github.com/webpack-contrib/mini-css-extract-plugin
npm WARN deprecated bower@1.7.2: This Bower version has SECURITY BUG THAT ALLOWS TO WRITE TO ARBITRARY FILE ON YOUR COMPUTER when you install malicious package. Please upgrade Bower to at least version 1.8.8 if you don't want to get hacked. More info: https://snyk.io/blog/severe-security-vulnerability-in-bowers-zip-archive-extraction/
npm WARN deprecated browserslist@1.4.0: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated express@2.5.11: express 2.x series is deprecated
npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated
npm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later
npm WARN deprecated json3@3.3.2: Please use the native JSON object instead of JSON 3
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated natives@1.1.6: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x.
npm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.
npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated istanbul@0.4.5: This module is no longer maintained, try this instead:
npm WARN deprecated   npm i nyc
npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN prefer global node-gyp@3.8.0 should be installed with -g
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9
npm WARN optional Skipping failed optional dependency /watchpack/chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9
npm WARN ngreact@0.3.0 requires a peer of angular@< 2.0.0 but none was installed.
npm WARN react-datetime@2.8.6 requires a peer of moment@>=2.16.0 but none was installed.
npm WARN react-test-renderer@15.6.2 requires a peer of react@^15.6.2 but none was installed.
npm WARN react-addons-test-utils@15.3.2 requires a peer of react@^15.3.2 but none was installed.
npm WARN ajv-keywords@3.4.0 requires a peer of ajv@^6.9.1 but none was installed.
npm WARN cdap-ui@4.3.5 No license field.
bower cask-angular-focus#*                  invalid-meta cask-angular-focus is missing "ignore" entry in bower.json
bower cask-angular-json-edit#*              invalid-meta cask-angular-json-edit is missing "ignore" entry in bower.json
bower cask-angular-theme#*                  invalid-meta cask-angular-theme is missing "ignore" entry in bower.json
bower cask-angular-capitalize#*             invalid-meta cask-angular-capitalize is missing "ignore" entry in bower.json
bower cask-angular-confirmable#*            invalid-meta cask-angular-confirmable is missing "ignore" entry in bower.json
bower cask-angular-eventpipe#*              invalid-meta cask-angular-eventpipe is missing "ignore" entry in bower.json
bower cask-angular-dispatcher#*             invalid-meta cask-angular-dispatcher is missing "ignore" entry in bower.json
bower cask-angular-window-manager#*         invalid-meta cask-angular-window-manager is missing "ignore" entry in bower.json
bower cask-angular-promptable#*             invalid-meta cask-angular-promptable is missing "ignore" entry in bower.json
bower cask-angular-socket-datasource#*      invalid-meta cask-angular-socket-datasource is missing "ignore" entry in bower.json
bower cask-angular-sortable#*               invalid-meta cask-angular-sortable is missing "ignore" entry in bower.json
bower cask-angular-observable-promise#*     invalid-meta cask-angular-observable-promise is missing "ignore" entry in bower.json
bower angular-inview#1.5.7                  invalid-meta angular-inview is missing "ignore" entry in bower.json
bower ngInfiniteScroll#1.2.1                    mismatch Version declared in the json (1.2.0) is different than the resolved one (1.2.1)
bower angular-ui-ace#bower                  invalid-meta angular-ui-ace is missing "ignore" entry in bower.json
bower ace-builds#^1                         invalid-meta ace-builds is missing "main" entry in bower.json
loaderUtils.parseQuery() received a non-string value which can be problematic, see https://github.com/webpack/loader-utils/issues/56
parseQuery() will be replaced with getOptions() in the next major version of loader-utils.

npm ERR! Linux 2.6.32-754.3.5.el6.x86_64
npm ERR! argv "/var/bamboo/xml-data/build-dir/CDAP-URUT0-BMA/cdap/cdap-ui/node/node" "/var/bamboo/xml-data/build-dir/CDAP-URUT0-BMA/cdap/cdap-ui/node/npm/bin/npm-cli.js" "run" "cdap-prod-build"
npm ERR! node v4.5.0
npm ERR! npm  v3.8.8
npm ERR! code ELIFECYCLE
npm ERR! cdap-ui@4.3.5 cdap-prod-build: `NODE_ENV=production webpack`
npm ERR! Exit status 2
npm ERR!
npm ERR! Failed at the cdap-ui@4.3.5 cdap-prod-build script 'NODE_ENV=production webpack'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the cdap-ui package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     NODE_ENV=production webpack
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs cdap-ui
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls cdap-ui
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /var/bamboo/xml-data/build-dir/CDAP-URUT0-BMA/cdap/cdap-ui/npm-debug.log