Build #241

Builds CDAP artifacts and performs unit tests

Build: #241 was successful

Job: Build Maven Artifacts was successful

Stages & jobs

  1. Tests

  2. Build Stage

  3. Assembly Stage

Job result summary

Completed
Duration
107 minutes
Agent
bamboo-agent06
Revision
57aca9f450d89d63365251cbb770b174ea3f37f3 57aca9f450d89d63365251cbb770b174ea3f37f3
Successful since
#7 ()

Error summary

The build generated some errors. See the full build log for more details.

warning: unable to rmdir hashing-tf-feature-generator: Directory not empty
warning: unable to rmdir logistic-regression-analytics: Directory not empty
warning: unable to rmdir naive-bayes-analytics: Directory not empty
warning: unable to rmdir skipgram-analytics: Directory not empty
warning: unable to rmdir tokenizer-analytics: Directory not empty
Cloning into 'condition-plugins'...
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
npm WARN deprecated react-file-download@0.3.2: WARNING: This project has been renamed to js-file-download. Use js-file-download instead.
npm WARN deprecated babel-preset-es2017@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated gulp-header@1.8.2: gulp-header 1.x is deprecated and will no longer be updated, please update to 2.x
npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated bower@1.7.2: We don't recommend using Bower for new projects. Please consider Yarn and Webpack or Parcel. You can read how to migrate legacy project here: https://bower.io/blog/2017/how-to-migrate-away-from-bower/
npm WARN deprecated browserslist@1.4.0: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated express@2.5.11: express 2.x series is deprecated
npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated
npm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated lodash.assign@4.2.0: This package is deprecated. Use Object.assign.
npm WARN prefer global node-gyp@3.8.0 should be installed with -g
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4
npm WARN optional Skipping failed optional dependency /watchpack/chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4
npm WARN ngreact@0.3.0 requires a peer of angular@< 2.0.0 but none was installed.
npm WARN react-datetime@2.8.6 requires a peer of moment@>=2.16.0 but none was installed.
npm WARN react-test-renderer@15.6.2 requires a peer of react@^15.6.2 but none was installed.
npm WARN react-addons-test-utils@15.3.2 requires a peer of react@^15.3.2 but none was installed.
npm WARN ajv-keywords@3.2.0 requires a peer of ajv@^6.0.0 but none was installed.
npm WARN cdap-ui@4.3.5 No license field.
bower angular-ui-ace#bower                  invalid-meta angular-ui-ace is missing "ignore" entry in bower.json
bower ngInfiniteScroll#1.2.1                    mismatch Version declared in the json (1.2.0) is different than the resolved one (1.2.1)
bower angular-inview#1.5.7                  invalid-meta angular-inview is missing "ignore" entry in bower.json
bower ace-builds#^1                             mismatch Version declared in the json (1.2.6) is different than the resolved one (1.4.1)
bower ace-builds#^1                         invalid-meta ace-builds is missing "main" entry in bower.json
loaderUtils.parseQuery() received a non-string value which can be problematic, see https://github.com/webpack/loader-utils/issues/56
parseQuery() will be replaced with getOptions() in the next major version of loader-utils.
npm WARN package.json cdap-ui@4.3.5 No license field.
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0