Build #35

Build: #35 was successful

Job: Build Artifacts was successful

Stages & jobs

  1. Build Stage

Job result summary

Completed
Duration
10 minutes
Agent
bamboo-agent05
Revision
e2604960ed806337127bc791010af318f5ebfde3 e2604960ed806337127bc791010af318f5ebfde3

Error summary

The build generated some errors. See the full build log for more details.

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
npm WARN deprecated react-file-download@0.3.2: WARNING: This project has been renamed to js-file-download. Use js-file-download instead.
npm WARN deprecated babel-preset-es2017@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!
npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
npm WARN deprecated gulp-header@1.8.2: gulp-header 1.x is deprecated and will no longer be updated, please update to 2.x
npm WARN deprecated babel-preset-es2015@6.3.13: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!
npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated bower@1.7.2: ...psst! Your project can stop working at any moment because its dependencies can change. Prevent this by migrating to Yarn: https://bower.io/blog/2017/how-to-migrate-away-from-bower/
npm WARN deprecated express@2.5.11: express 2.x series is deprecated
npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated
npm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN prefer global node-gyp@3.6.2 should be installed with -g
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4
npm WARN ngreact@0.3.0 requires a peer of angular@< 2.0.0 but none was installed.
npm WARN react-datetime@2.8.6 requires a peer of moment@>=2.16.0 but none was installed.
npm WARN react-test-renderer@15.6.2 requires a peer of react@^15.6.2 but none was installed.
npm WARN react-addons-test-utils@15.3.2 requires a peer of react@^15.3.2 but none was installed.
npm WARN cdap-ui@4.2.1-SNAPSHOT No license field.
npm WARN cdap-ui-upgrade@1.0.0 No repository field.
bower angular-ui-ace#bower                  invalid-meta angular-ui-ace is missing "ignore" entry in bower.json
npm WARN package.json cdap-ui@4.2.1-SNAPSHOT No license field.
+ tar xf cdap/cdap-ui/target/cdap-ui-4.2.1.1528161980711.tar.gz --transform 's/^[^\/]*/ui/'
++ /opt/maven/bin/mvn -q -f cdap/cdap-ui/pom.xml -Dexec.executable=echo '-Dexec.args=${ui.pack.version}' --non-recursive exec:exec
+ version=4.2.0_p6
+ echo 4.2.0_p6
+ echo cdap.version=4.2.1-SNAPSHOT
+ echo ui.pack.version=4.2.0_p6
+ echo ui.pack.file=cdap-ui-pack-4.2.0_p6.zip
+ zip -r -m cdap-ui-pack-4.2.0_p6.zip ui