Build #9

Checkoint

Build: #9 was successful

Job: Build Artifacts was successful

Stages & jobs

  1. Build Stage

Job result summary

Completed
Duration
14 minutes
Agent
bamboo-agent15
Revision
8dcf969f0ee5375ae0f579340eb367a427346739 8dcf969f0ee5375ae0f579340eb367a427346739

Error summary

The build generated some errors. See the full build log for more details.

npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
npm WARN deprecated bower@1.7.2: ..psst! While Bower is maintained, we recommend Yarn and Webpack for *new* front-end projects! Yarn's advantage is security and reliability, and Webpack's is support for both CommonJS and AMD projects. Currently there's no migration path, but please help to create it: https://github.com/bower/bower/issues/2467
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN prefer global marked@0.3.6 should be installed with -g
npm WARN prefer global colorguard@1.2.0 should be installed with -g
npm WARN prefer global node-gyp@3.6.2 should be installed with -g
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2
npm WARN ngreact@0.3.0 requires a peer of angular@< 2.0.0 but none was installed.
npm WARN react-datetime@2.8.6 requires a peer of moment@>=2.16.0 but none was installed.
npm WARN react-test-renderer@15.6.1 requires a peer of react@^15.6.1 but none was installed.
npm WARN react-addons-test-utils@15.3.2 requires a peer of react@^15.3.2 but none was installed.
npm WARN stylelint-webpack-plugin@0.4.2 requires a peer of stylelint@^7.7.0 but none was installed.
npm WARN postcss-reporter@4.0.0 requires a peer of postcss@^6.0.0 but none was installed.
npm WARN cdap-ui@4.3.0-SNAPSHOT No license field.
npm WARN cdap-ui-upgrade@1.0.0 No repository field.
bower angular-ui-ace#bower                        invalid-meta angular-ui-ace is missing "ignore" entry in bower.json
npm WARN package.json cdap-ui@4.3.0-SNAPSHOT No license field.
+ tar xf cdap/cdap-ui/target/cdap-ui-4.3.0.1501732865036.tar.gz --transform 's/^[^\/]*/ui/'
++ /opt/maven/bin/mvn -q -f cdap/cdap-ui/pom.xml -Dexec.executable=echo '-Dexec.args=${ui.pack.version}' --non-recursive exec:exec
+ version=4.2.0_p6
+ echo 4.2.0_p6
+ echo cdap.version=4.3.0-SNAPSHOT
+ echo ui.pack.version=4.2.0_p6
+ echo ui.pack.file=cdap-ui-pack-4.2.0_p6.zip
+ zip -r -m cdap-ui-pack-4.2.0_p6.zip ui